아래는 노드 패키지 모듈(npm) 설치 할 때 원하는 버전을 선택, 설치(인스톨)하는 방법을 알아봅니다.



# 노드 패키지 원하는 버전으로 설치하기
패키지 모듈을 npm으로 설치시 반드시 최신 버전이 필요한 것은 아닙니다. 오히려 그 이하의 버전이 필요하기도합니다. 특히 모듈 사이의 디펜던시가 버전과도 관련이 있기 때문이죠.

예를들어 Webpack을 설치한 경우 Webpack에서 사용하는 디펜던시 모듈의 버전이 상이한 경우 에러가 발생하기도 합니다. Webpack 버전을 올리기 보다 디펜던시의 다른 모듈의 버전을 맞춰(낮춰서) 사용하는 방법이 좋겠죠. 


! 모듈과 버전을 함께 설정, 인스톨 방법
이제 설치를 해보겠습니다. 예를들어 sass-loader 모듈을 ^7.3.1 버전으로 설치하고자 합니다. 여기서 ^ 기호는 앞의 버전 값인 7을 유지하고 최신 버전 설치를 의미합니다. 즉 7.x.x 이상의 버전으로 설치할 경우 사용하는 방법입니다.
npm install sass-loader@^7.3.1

이제 pacakge.json에는 sass-loader가 추가된 것을 알 수 있습니다.
"devDependencies": {
  ...
  "sass-loader": "^7.3.1",
  ...
}

참고로 설치 할 버전이^8.0.2인 경우라면 아래처럼 설치할 수 있겠죠.
npm install sass-loader@^8.0.2

물론 안전하게 uninstall 이 후 사용할 수도 있지만 버전 변경시 위와 같이 바로 업데이트가 가능합니다.


! 최신버전 latest로 업데이트 하기
추가로 npm module(모듈)을 최신 버전으로 업데이트 하는 방법을 알아봅니다. 이 경우 @latest를 사용합니다.

현재 antd가 4.6.0으로 설치되어 있군요. 이를 최신버전으로 업데이트 해보기 위해 아래의 명령어를 입력합니다.
npm install antd@latest

업데이트 후 버전을 확인해보니 4.6.1로 업데이트 되었습니다.

추가로 next 릴리즈 버전을 사용할 경우 아래와 같이 @next를 사용할 수 있습니다.
npm install antd@next

여기까지 노드 패키지 모듈의 설치 방법 중 원하는 버전을 선택하는 방법에 대하여 알아봤습니다.